nephila/dev/: nephila-widgets-2.0.1.post1 metadata and description

Homepage | Simple index

nephila plugins - Komaci 3.0

author Iacopo Spalletti
author_email i.spalletti@nephila.it
classifiers
  • Development Status :: 4 - Beta
  • Framework :: Django
  • Intended Audience :: Developers
  • Natural Language :: English
  • Framework :: Django
  • Framework :: Django :: 1.8
  • Framework :: Django :: 1.9
  • Framework :: Django :: 1.10
  • Programming Language :: Python :: 2
  • Programming Language :: Python :: 2.7
  • Programming Language :: Python :: 3
  • Programming Language :: Python :: 3.4
  • Programming Language :: Python :: 3.5
license Proprietary
platform
  • UNKNOWN
File Tox results History
nephila-widgets-2.0.1.post1.tar.gz
Size
682 KB
Type
Source
nephila_widgets-2.0.1.post1-py2.py3-none-any.whl
Size
767 KB
Type
Python Wheel
Python
2.7

New generation of nephila plugin

Installation

Add the following applications to your installed apps:

'nephila_widgets',
'nephila_widgets.base',
'nephila_widgets.conf',
'nephila_widgets.files',
'nephila_widgets.advanced',
'nephila_widgets.design',
'nephila_widgets.design.jessica',
'nephila_widgets.utils',
'djangocms_video',
'djangocms_googlemap',

Testing

nephila-widget being self-contained, setting up a running environment is trivial:

mkvirtualenv widgets
git clone git@gitix.iast.it:internal/nephila-widgets.git
cd nephila-widgets
pip install -r requirements-test.txt
python cms_helper.py server

Upgrading nephila-widgets to 1.1

  • Replace aldryn_video with djangocms_video in INSTALLED_APPS

Upgrading nephila-widgets to 1.0

As cmsplugin-filer plugins have been dropped, upgrading to nephila-widgets requires updated requirements and settings.

  • Make sure to keep cmsplugin-filer in requirements and settings
  • Backup your database
  • When running the migration, a data migration will move data to the new fields please check that everything is ok after the datamigration. It’s not reversible
  • Remove cmsplugin-filer plugins (all) from INSTALLED_APPS
  • Remove cmsplugin-filer from requirements

Upgrading cmsplugin-filer from 1.0 to 1.1

Due to changes in cmsplugin-filer/filer which moved ThumbnailOption model from the former to the latter, nephila-widgets must be migrated as well.

Migrating cmsplugin-filer to 1.1 and djangocms-blog up to 0.8.4

If you have nephila-widgets up to 0.7.0 (included) installed or you are upgrading from a previous nephila-widgets version together with cmsplugin-filer upgrade, you can just apply the migrations:

pip install cmsplugin-filer==1.1.1 django-filer==1.2.2 nephila-widgets==0.7.0
python manage.py migrate

Migrating cmsplugin-filer to 1.1 and nephila-widgets 0.7.1+

If you already a nephila-widgets 0.7.1+ or above, you have to de-apply some migrations when doing the upgrade:

python manage.py migrate nephila-widgets 0025 ## reverse for these migration is a noop
pip install cmsplugin-filer==1.1.1 django-filer==1.2.2
python manage.py migrate

Note

de-apply migration before upgrading cmsplugin-filer. If running before upgrade, the backward migration won’t alter anything on the database, and it will just allow the code to migrate ThumbnailOption from cmsplugin-filer to filer

History

2.0.1 (2018-07-18)

Fix image size if no thumbnail is given

2.0.0 (2018-07-08)

  • Add field that show the deeplink URL for the current plugin
  • Provide WidgetsAbstractImage to easily subclass the image plugin

1.1.2 (2018-07-08)

  • excluded_plugins is enforced in text plugin children

1.1.1 (2018-05-04)

  • Add field that show the deeplink URL for the current plugin

1.1.0 (2018-04-29)

  • Replace aldryn-video with djangocms-video

1.0.3 (unreleased)

  • excluded_plugins is enforced in text plugin children

1.0.2 (2018-05-04)

  • Add field that show the deeplink URL for the current plugin

1.0.1 (2018-03-13)

  • Add nephila_widgets.schema.RemoveField

1.0.0 (2018-02-24)

  • Drop cmsplugin-filer
  • Image plugins are now based on djangocms-picture
  • Add (optional) rich text editor for caption_text
  • Add support for django CMS 3.5

0.9.10 (2018-05-04)

  • Add field that show the deeplink URL for the current plugin

0.9.9 (2018-03-13)

  • Add nephila_widgets.schema.RemoveField

0.9.8 (2018-01-15)

  • Update slick-slider
  • Fix (?) heisenbug with form
  • Fixed (?) heisenbug with form
  • Add decorator to register plugins
  • Put google map js object in the global context
  • Load default jessica in test template
  • Add command to create sample widgets page
  • Fix double rendering of plugins
  • Enable gitlab pages
  • Avoid multiple global js vars with the same name
  • Update Slick Slider to 1.8.0

0.9.7 (2017-12-07)

  • Add template_name to WidgetsLinkPlugin fieldsets

0.9.6 (2017-11-27)

  • Add support for django 1.11
  • Allow extending private fields
  • Fix dots option in slider template
  • Fix django-appdata support
  • Exclude H1 from title levels except title plugin
  • Improve documentation

0.9.5 (2017-08-25)

  • Really fix jessica4 css columns discovery

0.9.4 (2017-08-24)

  • Fix jessica4 css columns discovery

0.9.3 (2017-08-23)

  • Implement separate template for link button in Image plugin

0.9.2 (2017-07-31)

  • Add link caption for plugin images

0.9.1 (2017-07-07)

  • Fix packaging issue

0.9.0 (2017-07-02)

  • Drop django CMS < 3.4
  • Move to CMS 3.4, djangocms-link 2.0, djangocms-googlemap 1.0
  • Add simpler lightbox

0.8.5 (2017-07-07)

  • Fix packaging issue

0.8.4 (2017-07-02)

  • Do not output columns in text children
  • Improve fieldsets arrangement
  • Add support for Jessica 4.0

0.8.3 (2017-03-23)

  • Restore image resizing fields

0.8.2 (2017-03-23)

  • Hide base image outside text plugins

0.8.1 (2017-03-11)

  • Add option to hide responsive images if user does not belong to nephila_widgets_responsive group

0.8.0 (2017-01-13)

  • Drop compatibility with filer<1.2, cmsplugin-filer<1.1, django CMS < 3.2
  • Add support for Djago 1.10
  • Add support for django CMS 3.4 / djangocms-text-ckeditor 3.2+
  • Reverse grid labels for the advance layout
  • Add id to plugins title

0.7.9 (2017-06-13)

  • Add tab plugins

0.7.8 (2016-07-13)

  • Fix error in picturefill support

0.7.7 (2016-07-13)

  • Fix error in custom widget setup

0.7.6 (2016-07-08)

  • Removed grid from section plugin
  • Added support for slick slider thumbnail templates

0.7.5 (2016-07-08)

  • Fixed image_text template
  • Improved dependencies pinning
  • Fixed admin user creation in migrations
  • Fixed form text widget setup
  • Fixed googlepmap template

0.7.4 (2016-07-05)

  • Fixed rich text widget usgae for usemap field
  • Enabled setting Google API key for map plugin

0.7.3 (2016-07-02)

  • Added WidgetsButtonPlugin
  • Added option to provide a custom method name for BasePluginMixin._fieldset_row

0.7.2 (2016-06-27)

  • Updated slick library
  • Fixed nephila_django templatetag
  • Fixed related_name issues with django CMS 3.3.
  • Fixed ThumbnailOption migration

0.7.1 (2016-06-27)

  • Fixed related_name issues with django CMS 3.3.1
  • Fixed dThumbnailOption migration

0.7.0 (2016-06-24)

  • Dropped Django<1.8 compatibility
  • Added fancy box gallery plugin
  • Added django CMS 3.3 support
  • Added compatibility with filer ThumbnailOption from cmsplugin_filer

0.0.1 (2015-01-03)

  • First experimental release